Помощь 1.6 => 1.7 миграция данных

millanapoly

Писатель
Регистрация
29 Дек 2019
Сообщения
3
Реакции
4
Добрый день!
На новом сайте установлена 1.7.6.0
migration pro версия 6.1.3

После коннекта со старым сайтом бесконечный экран "Waiting for connection to source shop"
Смена версий PHP вызывает ошибки.

Хром показывает вот такие ошибки

Код:
popper.js:29 Error: <svg> attribute height: Unexpected end of attribute. Expected length, "".
ii @ popper.js:29
icon-close.png:1

Uncaught (in promise) SyntaxError: Unexpected end of JSON input
    at icon-close.png:1

Может есть у кого идеи как лечить?
 
Последнее редактирование:

millanapoly

Писатель
Регистрация
29 Дек 2019
Сообщения
3
Реакции
4
Т.к. никто не ответил, напишу как решала. Пришлось взять на тестовый период более ровный хостинг и на PHP 5.6 всё законнектилось
 

grizla

Создатель
Регистрация
19 Янв 2015
Сообщения
10
Реакции
20
Всем привет! переносил магазин с помощью модуля Prestashop Upgrade and Migrate tool v6.0.2, с версии Для просмотра ссылки Войди или Зарегистрируйся на версию 1.7.6.4. Поставил скорость пенреноса на среднюю, всё перенеслось без ошибок. Пришлось потом ручками компоновать категории, но это уже мелочи. Но при проверке базы данных, через PHPMyadmin в таблице товара (Для просмотра ссылки Войди или Зарегистрируйся) перенеслись не все столбцы, а именно столбец `xml`, с персональными кодами для синхронизации с программой 1С, почему-то не перенёсся. Странное исключение...вроде должно копировать полную таблицу, а почему-то обрезал поля, которые были сделаны вручную под модуль ecm_cmlid.
 

_sashok

PrestaShop Expert
Регистрация
15 Июл 2011
Сообщения
2.312
Реакции
4.112
Всем привет! переносил магазин с помощью модуля Prestashop Upgrade and Migrate tool v6.0.2, с версии Для просмотра ссылки Войди или Зарегистрируйся на версию 1.7.6.4. Поставил скорость пенреноса на среднюю, всё перенеслось без ошибок. Пришлось потом ручками компоновать категории, но это уже мелочи. Но при проверке базы данных, через PHPMyadmin в таблице товара (Для просмотра ссылки Войди или Зарегистрируйся) перенеслись не все столбцы, а именно столбец `xml`, с персональными кодами для синхронизации с программой 1С, почему-то не перенёсся. Странное исключение...вроде должно копировать полную таблицу, а почему-то обрезал поля, которые были сделаны вручную под модуль ecm_cmlid.

модуль наоборот сделал всё корректно и правильно, чтобы "левый" мусор не копировался

кастомные поля можно доперенести через импорт csv в phpmyadmin
 

grizla

Создатель
Регистрация
19 Янв 2015
Сообщения
10
Реакции
20
Сделал перенос по другому, если кому интересно: две базы данных, старая karprint_db и новая karprint_pr. В каждой есть таблица ps_product, в этой таблице есть столбец `xml` (id_cml коды для идентификации каждого товара, при связи с 1С программой). Для переноса данных из karprint_db в karprint_pr в столбец `xml`, был сделан запрос в Phpmyadmin:
use karprint_pr;

update ps_product set `xml`=

(select `xml` from karprint_db.ps_product t where ps_product.Id_product =t.Id_product);


Это может быть применимо для копирования и к другим таблицам и полям.
 

SubotinJ

Писатель
Регистрация
14 Апр 2020
Сообщения
5
Реакции
5
Кто подскажет, стоит ли сейчас переходить с 1.6 на 1.7? и как сейчас вообще с переездом, легко ли перенести магазин с 6к товарами?
 

fantats

Постоялец
Регистрация
30 Ноя 2014
Сообщения
321
Реакции
185
Кто подскажет, стоит ли сейчас переходить с 1.6 на 1.7? и как сейчас вообще с переездом, легко ли перенести магазин с 6к товарами?
С модулем миграции вроде все нормально перенеслось
 

mmucool

Писатель
Регистрация
19 Дек 2016
Сообщения
1
Реакции
0
Добрый день!
На новом сайте установлена 1.7.6.0
migration pro версия 6.1.3

После коннекта со старым сайтом бесконечный экран "Waiting for connection to source shop"
Смена версий PHP вызывает ошибки.

Та же проблема (( решение нашли?
 

klifort

Создатель
Регистрация
31 Дек 2014
Сообщения
13
Реакции
9
Добрый день!
На новом сайте установлена 1.7.6.0
migration pro версия 6.1.3

После коннекта со старым сайтом бесконечный экран "Waiting for connection to source shop"
Смена версий PHP вызывает ошибки.

Хром показывает вот такие ошибки

Код:
popper.js:29 Error: <svg> attribute height: Unexpected end of attribute. Expected length, "".
ii @ popper.js:29
icon-close.png:1

Uncaught (in promise) SyntaxError: Unexpected end of JSON input
    at icon-close.png:1

Может есть у кого идеи как лечить?

у меня было такое
Решил -> сначало очистил модуль "migration pro" далее удалил сам модуль "migration pro" i так же модуль "bridge connector module" на престе 1.6
потом ещо раз установил модуль с самогьо начала и все заработало
 
Сверху