Информация Prestashop 1.7.6.x

callist.spb

Создатель
Регистрация
28 Сен 2018
Сообщения
16
Реакции
10
в 1.7.6.3 есть досадных баг, не позволяющий нормально на странице товара переключаться между атрибутами (для товаров, у которых одновременно много комбинаций)

в 1.7.6.4 будет пофиксено
Для просмотра ссылки Войди или Зарегистрируйся

а пока можно руками у себя просто запятую добавить

233 строка /themes/core.js

добавляем запятую

было:
(0,r.default)(".quickview .product-variants

стало:
(0,r.default)(".quickview .product-variants,


Для просмотра ссылки Войди или Зарегистрируйся

Посмотреть вложение 107632
Даже если две комбинации не переводит выделение атрибута.
Спасибо!
 

evgenij.sobolev

Мой дом здесь!
Регистрация
8 Дек 2015
Сообщения
340
Реакции
469
Подскажите, как в престе 1.7.6.5 изменить формат отображения даты?
Сейчас отображается в таком формате: Thu.07.20
А надо изменить на привычное нам 2.07.20
 

evgenij.sobolev

Мой дом здесь!
Регистрация
8 Дек 2015
Сообщения
340
Реакции
469
Подскажите, как в престе 1.7.6.5 изменить формат отображения даты?
Сейчас отображается в таком формате: Thu.07.20
А надо изменить на привычное нам 2.07.20

Сам нашел..
Если кому-то понадобится: Локализация -> Язык,
установить формат даты d.m.y
 

_sashok

PrestaShop Expert
Регистрация
15 Июл 2011
Сообщения
2.317
Реакции
4.114
для всех, у кого не устанавливается чистая преста 1.7 при выборе рус.яза

psgdpr1: Невозможно установить модуль "psgdpr", Длина свойства Tab->name составляет 70 симв. Должно быть между 0 и 64 симв.

да, есть такой баг из-за кириллицы в названии модуля, причём это на стороне аддонсов - с ними общаться пока времени-желания нет

поэтому алгоритм фикса нашёл такой достаточно простой:

- устанавливаем самую свежую версию ядра, например 1.7.6.7 (Для просмотра ссылки Войди или Зарегистрируйся)
- ругаться будет в любом случае
psgdpr1: Невозможно установить модуль "psgdpr",Длина свойства Tab->name составляет 70 симв. Должно быть между 0 и 64 симв.
так как этот модуль качается всегда заново с аддонс сервера
- страницу установки в браузере - не закрываем
- ОК - хрен с вами - жабоедами :)
- заходим в файл модуля \psgdpr\psgdpr.php
- заменяем
248:
$tab->name = array_fill_keys(
Language::getIDs(false),
$this->displayName
);
на
$tab->name = 'GDPR';

- меняем владельца файла на root-root чтобы не затирался при второй итерации установки (на шаред-хостинге не проверял, но может сработает и установка прав 444)
- удаляем все таблицы через phpMyAdmin
- возвращаемся в браузер, нажимаем на установку заново
- profit
 
Сверху