Помогите установить сборку городского портала

unkn0wn

Гуру форума
Регистрация
22 Дек 2006
Сообщения
164
Реакции
81
Восьмая еще даже в альфу не вышла, дата релиза назначена на август, но судя по кол-ву запиленных фич, в какое-то более-менее стабильное состояние она выйдет только к новому году. В то же время минусы шестерки я уже описал выше, так что смысл делать новый портал на ней - чистой воды самоубийство: завтра ютуб поменяет механизм вставки видео, и модуль media: youtube придется патчить руками, и так будет с половиной модулей через какое-то время. Конечно, на ней работает большинство крупных порталов, но они и затевались несколько лет назад, когда семерки не было даже альфы, и в них запилено большое кол-во патчей, так что им смысла нет переходить на новый движок, когда и старый деньги приносит. Кроме того, архитектурно семерка гораздо ближе к восьмерке, чем к шестерке (entity, ядерный CCK, переработанный механизм мультиязычности), так что переход должен быть проще.
 

risk_plus

Постоялец
Регистрация
2 Мар 2008
Сообщения
75
Реакции
42
Спасибо за разъяснения версионности друпала. В таком случае можно наверное все же семерку использовать и пробовать на ней пилить портал сборку. Ясно в общем.:)
 

3d tiger

Мой дом здесь!
Регистрация
14 Июн 2008
Сообщения
531
Реакции
385
  • Заблокирован
  • #25
Ни по одной ссылке файла нет, перезалейте
 

SiriusD

Профессор
Регистрация
27 Июн 2009
Сообщения
207
Реакции
49
Подскажите кто нибудь решил проблему с ошибкой на главной странице????

user warning: Mixing of GROUP columns (MIN(),MAX(),COUNT(),...) with no GROUP columns is illegal if there is no GROUP BY clause query: SELECT COUNT(node.nid) AS nid, node.created AS node_created FROM node node INNER JOIN content_type_work node_data_field_work_type ON node.vid = node_data_field_work_type.vid INNER JOIN term_node term_node ON node.vid = term_node.vid WHERE (node.type in ('work')) AND (node_data_field_work_type.field_work_type_value = 'Вакансия') AND (node.status = 1) AND (term_node.tid = 887) in D:\Program Files\VertrigoServ\www\includes\common.inc(1696) : eval()'d code on line 13.

Я запускал на вертуалке! На хостинге тажа ошибка!!!
 

VinDuran

Профессор
Регистрация
9 Ноя 2011
Сообщения
151
Реакции
40
Подскажите кто нибудь решил проблему с ошибкой на главной странице????

user warning: Mixing of GROUP columns (MIN(),MAX(),COUNT(),...) with no GROUP columns is illegal if there is no GROUP BY clause query: SELECT COUNT(node.nid) AS nid, node.created AS node_created FROM node node INNER JOIN content_type_work node_data_field_work_type ON node.vid = node_data_field_work_type.vid INNER JOIN term_node term_node ON node.vid = term_node.vid WHERE (node.type in ('work')) AND (node_data_field_work_type.field_work_type_value = 'Вакансия') AND (node.status = 1) AND (term_node.tid = 887) in D:\Program Files\VertrigoServ\www\includes\common.inc(1696) : eval()'d code on line 13.

Я запускал на вертуалке! На хостинге тажа ошибка!!!

Версия php у тебя скорее всего 5.3, а для скрипта необходимо 5.2

Поставь старый денвер или на хостинге у себя в настройках поменяй.
 

SiriusD

Профессор
Регистрация
27 Июн 2009
Сообщения
207
Реакции
49
У меня стоит PHP Version 5.3.5 а как подскажите поменять версию руками можно просто переустанавливать на 5.2 не хочется так как стоят другие сайты!

А на локалке стоит PHP Version 5.2.6 но ошибка и там и там!
 

VinDuran

Профессор
Регистрация
9 Ноя 2011
Сообщения
151
Реакции
40
У меня стоит PHP Version 5.3.5 а как подскажите поменять версию руками можно просто переустанавливать на 5.2 не хочется так как стоят другие сайты!

А на локалке стоит PHP Version 5.2.6 но ошибка и там и там!


Запускал на денвере на локалке. Специально перепроверил. Скрипт работает, но с глюками (они и были в самом релизе, который выкладывали).

Сервер баз данных

Сервер: 127.0.0.1 via TCP/IP
Программа: MySQL
Версия программы: 5.5.25 - MySQL Community Server (GPL)
Версия протокола: 10
Пользователь: root@localhost
Кодировка сервера: UTF-8 Unicode (utf8)

Веб-сервер

Apache/2.2.22 (Win32) mod_ssl/2.2.22 OpenSSL/1.0.1c PHP/5.2.12
Версия клиента базы данных: libmysql - 5.0.51a
PHP расширение: mysqli


phpMyAdmin

Информация о версии: 3.5.1
 
Сверху