Скрипт AсtiveCollab :: Все версии :: Модули :: Переводы :: Решения

Шумадан

Хабарра!!11
Регистрация
6 Фев 2008
Сообщения
1.746
Реакции
2.209
Встречайте active.collab 5
ActiveCollab поможет вашей команде работать продуктивно! Мощный и в то же время простой инструмент управления проектами. В нем есть все, что необходимо вашему бизнесу!

Для просмотра ссылки Войди или Зарегистрируйся

my-work@2x.jpg

calendar@2x.jpg

collaborative-writing@2x.jpg

themes@2x.jpg

Установщик 5.13.133
Уже все как надо. Няма-няма используем, если установщик скачан в другом месте.

Няма-няма

Установка обновлений из архива (ручной режим)

Полезные ссылки
Для просмотра ссылки Войди или Зарегистрируйся
Для просмотра ссылки Войди или Зарегистрируйся
Для просмотра ссылки Войди или Зарегистрируйся
 

Вложения

  • activeCollab-logo-grey.png
    activeCollab-logo-grey.png
    7,6 KB · Просмотры: 10.591
  • ac0.png
    ac0.png
    104,8 KB · Просмотры: 12.817
  • ac1.jpg
    ac1.jpg
    98,7 KB · Просмотры: 12.790
  • ac2.jpg
    ac2.jpg
    86,5 KB · Просмотры: 12.770
  • ac3.jpg
    ac3.jpg
    107,9 KB · Просмотры: 12.715
Последнее редактирование:
No need to null, as licence checks are only fired when upgrading.
Yes I've installed it over my 6.2.163 and now 7.1.0 works fine.

Regarding your elasticsearch question - is your elasticsearch server running? If it's on separate server, are you sure firewall allows your AC to connect it on its port (defaults to port 9200)?

I refresh installed ActiveCollab 6.1.53, it is nulled, and I upgrade to 6.2.163, it is shows sucessfully, but then it seems not nulled, all the function is disable because no valid license.

I installed elasticsearch on my VPS server, the same server as Activcollab, the URL is
Для просмотра ссылки Войди или Зарегистрируйся

root@activecolab:/var/www# php tasks/activecollab-cli.php search:index
PHP Notice: Undefined offset: 1 in /var/www/activecollab/6.1.53/angie/classes/application/AngieApplication.class.php on line 286
+----------+----------------------------------+
| Property | Value |
+----------+----------------------------------+
| adapter | Angie\Search\Adapter\Queued |
| mode | single-tenant |
| index | active_collab_123456 (not found) |
+----------+----------------------------------+
 
I refresh installed ActiveCollab 6.1.53, it is nulled, and I upgrade to 6.2.163, it is shows sucessfully, but then it seems not nulled, all the function is disable because no valid license.
Can you provide the screenshot? Never saw anything like that and was sure license is only checked at install and upgrade.

I installed elasticsearch on my VPS server, the same server as Activcollab, the URL is
Для просмотра ссылки Войди или Зарегистрируйся
In your settings you need to put localhost:9200 without http://

root@activecolab:/var/www# php tasks/activecollab-cli.php search:index
PHP Notice: Undefined offset: 1 in /var/www/activecollab/6.1.53/angie/classes/application/AngieApplication.class.php on line 286
Try running it on PHP 7.1 instead of 7.2 or up.

All in all - just upgrade to 7.1 with PHP 7.4 so that you're not solving irrelevant or old problems.
 
I just upgrade to 6.0.50, and I just fill the elasticsearch server, show error:
2020-12-20-15-02-13.jpg

2020-12-20-14-56-30.jpg
 
I just successfully upgrade to 7.1.0, All the functions are OK only accept ElasticSearch

2020-12-20-15-07-54.jpg
 
I just successfully upgrade to 7.1.0, All the functions are OK only accept ElasticSearch
Congrats.

Official AC help documentation says it needs ElasticSearch 6.x. One of your screenshots shows you're running 7.10.1. Reading docs help, do that instead of asking other people doing that for you.
 
Congrats.

Official AC help documentation says it needs ElasticSearch 6.x. One of your screenshots shows you're running 7.10.1. Reading docs help, do that instead of asking other people doing that for you.

Sorry, My problem. I have to uninstall Elasticsearch 7.x and reinstall 6.x. Thank you for your information, I wasted a long time on this problem.
 
How to disable the new update available message on the system setting page?
 
Sorry, My problem. I have to uninstall Elasticsearch 7.x and reinstall 6.x. Thank you for your information, I wasted a long time on this problem.
The "like" button under my post says "thank you" more than words do ;)

How to disable the new update available message on the system setting page?
activecollab/7.1.0/angie/frameworks/environment/handlers/on_system_status.php line 50 change to this:
Код:
$status['new_version_available'] = false;
 
Покопался в исходниках от 7.0.5, нашел эндпоинты их API, потыкался в них немного и выкачал свежак - 7.1.0 со всеми папками. Процедура апдейта такая же - разархивировать в /activecollab/ и запустить
php tasks/activecollab-cli.php upgrade -v --dont-download-latest
Обязательно РНР 7.4.
Ловите:


Очень хорошо, к сожалению, у меня нет 10 симпатий. :conf:

Very good, unfortunately I don't have 10 likes. :conf:
 
Назад
Сверху