[ZFS] пропали точки монтирования

Статус
В этой теме нельзя размещать новые ответы.

xilix

Постоялец
Регистрация
22 Ноя 2009
Сообщения
126
Реакции
19
После отключения электроэнергии на несколько часов, произошел странный глюк с zfs. Пропали все точки монтирования и соответственно файлы.

Код:
    # ls /mnt/vault02
    #


по статусу вроде все нормально

Код:
    # zpool status
      pool: vault02
     state: ONLINE
     scrub: scrub completed with 0 errors on Sat May 22 10:23:02 2010
    config:

            NAME        STATE     READ WRITE CKSUM
            vault02     ONLINE       0     0     0
              ad20p1    ONLINE       0     0     0

    errors: No known data errors


zfs list показывает что данные на месте

Код:
    # zfs list
    NAME             USED  AVAIL  REFER  MOUNTPOINT
    vault02          734G  1.07T    23K
    vault02/data      18K  1.07T    18K  /data
    vault02/games     18K  1.07T    18K  /games
    vault02/mmedia   734G  1.07T   734G  /mmedia
    vault02/users     18K  1.07T    18K  /users

хотел сделать детач, а потом аттач, но не получилось

Код:
    # zpool detach vault02 ad20p1
    cannot detach ad20p1: only applicable to mirror and replacing vdevs

хотя никакого миррора там нет

вот еще

Код:
    # zpool import
      pool: vault02
        id: 14298189775326448960
     state: ONLINE
    action: The pool can be imported using its name or numeric identifier.
    config:

            vault02     ONLINE
              ad20p1    ONLINE
    # zpool import vault02
    cannot mount 'vault02': No such file or directory
    # zpool import
    no pools available to import

система 7.1-RELEASE
врядли что-то изменится, если обновлю.

как полечить? не хотелось бы данные терять.
 

xilix

Постоялец
Регистрация
22 Ноя 2009
Сообщения
126
Реакции
19
данные вытянул, примонтировал, но после перезагрузки все равно слетает. каждый раз приходится делать zpool import. пока еще не придумал как это пофиксить. система уже 8.1, а zfs версии 14.
 
Статус
В этой теме нельзя размещать новые ответы.
Сверху