Релизы и обновления NetCat.

kgtu5

Создатель
Регистрация
1 Июн 2013
Сообщения
17
Реакции
5
А с 5.1 до 5.5 одним каким файлом обновляться ?
такого файла нет, только последовательно повышая версию несколькими обновлениями
следующая требуемая версия указывается на вкладке обновлений
 

erynrandir

Писатель
Регистрация
31 Дек 2012
Сообщения
5
Реакции
0
а не сохранились у кого?

nc322extra-nc350extra.tgz
nc350extra-nc351extra.tgz

тут нашел "301 до 351.rar", в нем по 3.22 там идет для extra, а оставшиеся для standart, не ставятся

клиент попросил сайт хоть как-то обновить. был 3.0)
 

kgtu5

Создатель
Регистрация
1 Июн 2013
Сообщения
17
Реакции
5
а не сохранились у кого?

nc322extra-nc350extra.tgz
nc350extra-nc351extra.tgz

тут нашел "301 до 351.rar", в нем по 3.22 там идет для extra, а оставшиеся для standart, не ставятся

клиент попросил сайт хоть как-то обновить. был 3.0)
Для просмотра ссылки Войди или Зарегистрируйся
те которые эксперементальные работают норм, но на всякий случай сделайте бекап.

P.S. могу помочь с обновлением.
 

erynrandir

Писатель
Регистрация
31 Дек 2012
Сообщения
5
Реакции
0
спасибо большое за ссылку!

последний в списке 322, но при установке nc322extra-nc350extra_exp

Патч не предназначен для используемой версии системы NetCat, текущая версия 3.2, патч для версии .
Инсталляция патча невозможна.

То есть версию из патча не видит - сталкивался ли кто-нибудь?

Хотел бы сам разобраться

А с 3.5 на 4 файла нет - там нет вариантов?
 

max-sparker

Профессор
Регистрация
9 Мар 2008
Сообщения
171
Реакции
44
спасибо большое за ссылку!
Патч не предназначен для используемой версии системы NetCat, текущая версия 3.2, патч для версии .
Инсталляция патча невозможна.

Может Вам необходимо обновиться для начала с 3.2.0 ?
nc320extra-nc321extra
nc321extra-nc322extra
 

erynrandir

Писатель
Регистрация
31 Дек 2012
Сообщения
5
Реакции
0
Они установлены

Для просмотра ссылки Войди или Зарегистрируйся

Я пробовал запросом вручную менять версию

Для просмотра ссылки Войди или Зарегистрируйся

Но тогда получаю такое сообщение - все равно проблема в патче

Патч не предназначен для используемой версии системы NetCat, текущая версия 3.22, патч для версии .
Инсталляция патча невозможна.

UPD: решено! я просто распаковал содержимое в tmp, предыдущие работали прям файлами, забыл про такой способ

UPD2: после установки

PHP Fatal error: Uncaught exception 'Exception' with message 'Unable load system class "nc_Event"!' in /.../netcat/system/nc_core.class.php:83

вот в этом коде проблема:

if ( is_callable( array( $class_name, '__construct' ) ) ) {
die('xxx'); // неа
$this->$object = call_user_func_array( array( new ReflectionClass($class_name), 'newInstance' ), $args );
}

if (!$this->$object) throw new Exception ("Unable load system class \"".$class_name."\"!");

is_callable не срабатывает
 
Последнее редактирование:

kgtu5

Создатель
Регистрация
1 Июн 2013
Сообщения
17
Реакции
5
заменил экспериментальные, пробуйте еще раз
 

erynrandir

Писатель
Регистрация
31 Дек 2012
Сообщения
5
Реакции
0
Благодарю!

Сейчас у меня ошибка 500

Попробую поднять копию с 322 и заново поставить
 

kgtu5

Создатель
Регистрация
1 Июн 2013
Сообщения
17
Реакции
5
500 - при этой ошибке сразу смотрите error.log
 
Сверху