проблема с SSL и Cron в NetCat

nfox

Создатель
Регистрация
16 Апр 2013
Сообщения
39
Реакции
94
Здравствуйте ув. форумчане,
прошу помощи так как на офф сайте ничего дельного не сказали, не как не могу добится нормальной работы SSL и Cron. То есть cron запускается и запускает установленные задачи (mailer, subscribe, indexing) но они не выполняются. Редирект на SSL прописан в корневом .htaccess в папке кота. В логах ничего не видно, то есть пусто. Кот стоит на Parallels Plesk. Crontab.php запущен через CLI

Есть какие идеи или может кто успешно решил проблему ?
 

metsys

Хранитель порядка
Регистрация
27 Апр 2014
Сообщения
592
Реакции
655
а какая связь между SSL и Cron? (подозреваю, такая же как между морскими свинками и морем)
проверьте отработку Crontab.php вручную, проверьте исполнение скриптов и только потом суйте в крон...
 

nfox

Создатель
Регистрация
16 Апр 2013
Сообщения
39
Реакции
94
а какая связь между SSL и Cron? (подозреваю, такая же как между морскими свинками и морем)
проверьте отработку Crontab.php вручную, проверьте исполнение скриптов и только потом суйте в крон...
Дело в том что без этого

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) Для просмотра ссылки Войди или Зарегистрируйся

Все работает как надо, но как только добавлю так ломается индексация и прочие скрипты которые должны выполнятся. Сам crontab.php из netcat/admin/ запускается без проблем и запускает другие задачи но вот дальше уже они никуда не идут
 

metsys

Хранитель порядка
Регистрация
27 Апр 2014
Сообщения
592
Реакции
655
Крон виноват в том, что Вы ломаете работу crontab.php ?
 

nfox

Создатель
Регистрация
16 Апр 2013
Сообщения
39
Реакции
94
Крон виноват в том, что Вы ломаете работу crontab.php ?
не Вы наверно меня не поняли, в самой CMS в разделе задачи все стоит по стандарту вот
tasks.jpg

За этот список отвечает crontab.php который запускается в Plesk через CLI, дело в том что все скрипты запускаются но не выполняют свою задачу когда в .htaccess установлен редирект на SSL когда НЕ установлен все работает
 
Сверху