p403_formbuilder invalid e-mail

foray

Постоялец
Регистрация
21 Янв 2010
Сообщения
63
Реакции
1
У меня проблема-p403_formbuilder чтобы настроить,нужно Create New Recipient.Ввожу нормальный e-mail,получаю The email address you have entered is invalid ....В чём проблема?...Раньше сталкивался,но решения сейчас найти не могу...
 

Gusar

Постоялец
Регистрация
24 Янв 2008
Сообщения
96
Реакции
41
У меня проблема-p403_formbuilder чтобы настроить,нужно Create New Recipient.Ввожу нормальный e-mail,получаю The email address you have entered is invalid ....В чём проблема?...Раньше сталкивался,но решения сейчас найти не могу...

Там 2 поля, повнимательнее, такое бывает когда путаю Name и E-mail поля
 

foray

Постоялец
Регистрация
21 Янв 2010
Сообщения
63
Реакции
1
точно не путаю!
 

foray

Постоялец
Регистрация
21 Янв 2010
Сообщения
63
Реакции
1
....в контактной форме такая-ж фигня....это что-то в настройках?
 

foray

Постоялец
Регистрация
21 Янв 2010
Сообщения
63
Реакции
1
в файле p403_settings закомментировал код

Код:
else if(strlen($email) > 0 && !ereg("^([A-Za-z0-9]+_+)|([A-Za-z0-9]+\-+)|([A-Za-z0-9]+\.+)|([A-Za-z0-9]+\++))*[A-Za-z0-9]+@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([a-zA-Z0-9\-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)$", $email))
	{
		echo "The email address you have entered is invalid";
		DisplayRecipient();
	}

После этого плагин позволил ввести реципиента без ругани....Что в коде не так?
 

foray

Постоялец
Регистрация
21 Янв 2010
Сообщения
63
Реакции
1
....но плагин после заполнения формы всё равно выдает сообщение о неправильном имэйле и не отправляет данные заполненной формы на указанный мэйл админа-получателя....хотя в базу отправляет,запись есть о новом респонденте
 

SaM1001

Постоялец
Регистрация
15 Янв 2008
Сообщения
131
Реакции
20
Версию плагина и саба в студию, а то на так на кофейной гуще легче гадать
 
Сверху