как отключить лог в сабе?

foray

Постоялец
Регистрация
21 Янв 2010
Сообщения
63
Реакции
1
было один в один...перешёл на другой сервак хостинка,а там php 5....У меня Subdr 2.5.3....На работе сайта не сказалось,но логи начали переполняться сообщениями об ошибках,связанных с php 5....
> Function ereg_replace() is deprecated in /home/r..
это не фатальная ошибка, а всего лишь предупреждение о том что функция ereg_replace() устарела. она все еще нормально работает, но в будущих версиях PHP (сорее всего только в PHP6) будет удалена....в корневом файле php.ini прописал строчку:
error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED
в этом случае php не будет сообщать об использовании устаревших функций.
 

PUNKER

Создатель
Регистрация
31 Окт 2006
Сообщения
22
Реакции
4
Народ, а может просто обновить версию саба и там они это уже подлатали?
У меня версия 2.4.3.1, кто знает на какую можно безболезненно обновиться? На трёшку переходить как-то боязно, а предупреждения реально достали((
 

Gusar

Постоялец
Регистрация
24 Янв 2008
Сообщения
96
Реакции
41
Мы переписали (заменили) функции все под php 5x для саба 2.5.3. Заняло часа три четыре. Лог чистый теперь.
 

skitalec

Постоялец
Регистрация
21 Авг 2007
Сообщения
57
Реакции
0
А можно обнародовать правленную версию саба для тех кто им пользуется но не силен в программировании ??
 

Gusar

Постоялец
Регистрация
24 Янв 2008
Сообщения
96
Реакции
41
А можно обнародовать правленную версию саба для тех кто им пользуется но не силен в программировании ??

К сожалению нет. Не будет работать, были переписаны и вызовы и названия некоторых функций. А для базовой 2.5.3 не делалось, ибо не работаем с ней уже лет 5 как.
 

asmedia

Писатель
Регистрация
10 Ноя 2011
Сообщения
2
Реакции
0
К сожалению нет. Не будет работать, были переписаны и вызовы и названия некоторых функций. А для базовой 2.5.3 не делалось, ибо не работаем с ней уже лет 5 как.
Жалко! Нужна была правленная версия
 
Сверху